autopulse unit

View previous topic View next topic Go down

autopulse unit

Post  Guest on September 25th 2009, 6:07 pm

my 12 hp 1966 suburban tractor wont start fuel is in the filter but wont get through autopulse unit does anybody else ever had this problem

Guest
Guest


Back to top Go down

Re: autopulse unit

Post  tractor_guy on October 6th 2009, 12:06 am

Carlo,
Generic vacuum fuel pumps and/or rebuild kits are available, but I have had success just eliminating them entirely. Run the fuel line directly to the carburetor. The fuel tank sits above carb level so it's gravity fed.

When you remove the pump, you will have to add a hose fitting in its place. I THINK it's 1/4-18 male pipe thread on one end and 1/4 male hose barb on the other. Check it first to be sure.

Jason

tractor_guy

Number of posts : 9
Registration date : 2009-09-13

View user profile

Back to top Go down

Re: autopulse unit

Post  spence on October 6th 2009, 10:15 am

I second that suggestion by Jason. I've eliminated the fuel pump on my tractors also. I never experienced a problem. Then again, I live in Southern New Jersey. Our landscape is flat as a pancake. If you live in a hilly location, then there may be an issue.

I've heard of many who use a very low pressure electric pump to replace the vacuum units.

spence
Admin

Number of posts : 168
Registration date : 2008-05-15

View user profile

Back to top Go down

Re: autopulse unit

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum