ss14 won't start--electrical problem

View previous topic View next topic Go down

ss14 won't start--electrical problem

Post  vinman on June 12th 2010, 3:05 pm

Hi all-- I'm looking for help. My ss14 was running fine last season, except it would turn over more slowly each time. By end of summer, the starter would revolve as slowly as one turn every 5 or 10 seconds!! But it would still start eventually (the engine would suddenly turn over at the normal rate).
This season engine will not start at all. Starter does not move at all when ignition is turned to "start". The "on" position is fine (current goes to ammeter and the headlights light when lightswitch is on). I did check wires from ignition switch and found that when ignition is turned to "start", current is ONLY in red wire from battery to ignition switch AND in red wire from ignition switch to starter safety switch. However, no current goes from starter safety switch to starter. Both terminals on starter are showing no current when ignition is turned to "Start".
I did switch out the starter, but problem remained the same.
Do I have a bad starter safety switch? Bad ignition switch? Loose wire to engine or to ground? Please help, as I am not very experienced in fixing these types of problems. Thanks.

vinman

Number of posts : 5
Registration date : 2010-06-12

View user profile

Back to top Go down

Re: ss14 won't start--electrical problem

Post  joe k. on June 13th 2010, 10:08 am

How about bypassing the switch to see if the switch is the problem?
Thanks,
Joe Laughing

joe k.
Guest


Back to top Go down

Re: ss14 won't start--electrical problem

Post  vinman`` on June 14th 2010, 12:01 pm

Good idea-- I will try that and see what happens

vinman``
Guest


Back to top Go down

update

Post  vinman on June 19th 2010, 1:51 pm

Ok, I did bypass the starter safety switch. The engine immediately began to turn over when I tried to start it. SO the issue is with the starter safety switch--either it is bad OR it is doing it's job of preventing the engine from starting due to some hazard that I am unaware of.

I have considered removing the switch entirely, but I hesitate to do that because the switch is there for a reason. I know Sears does not sell this part. I also don't recall it ever being listed in ebay. Does anybody know where I can get a used switch or a compatible one from another make/model?

vinman

Number of posts : 5
Registration date : 2010-06-12

View user profile

Back to top Go down

Re: ss14 won't start--electrical problem

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum